pyboard v1.1 stuck at DFU mode?

The official pyboard running MicroPython.
This is the reference design and main target board for MicroPython.
You can buy one at the store.
Target audience: Users with a pyboard.
Post Reply
jonpedros
Posts: 2
Joined: Thu Aug 04, 2022 1:03 am

pyboard v1.1 stuck at DFU mode?

Post by jonpedros » Thu Aug 04, 2022 1:17 am

Hello everyone.

I've bought a pyBoard v1.1 recently and it worked correctly with my code. However, after upgrading the firmware from v1.16 (not sure) to 1.19.1 through DfuSe without errors, the board got really weird, failing to connect to my program. After a bit of random resetting and filesystem resetting to no avail, I decided to try to upgrade again, wondering if I used a wrong firmware version. The upgrade was interrupted midway with an error.

Now the pyBoard is stuck with the green and orange lights constantly lit, and the yellow one in the middle very faintly lit. The board is not identified at all by Windows. No notification sound after connecting, even. My PC has the specific micropython drivers, but the other PC I tried does not.

I tried different micro USB cables and tried connecting to another PC, but it won't show up. It also does not respond at all to the reset and USR buttons. Also tried connecting the 3V3 pin to the BOOT0 and pressing reset to go into DFU mode but no go.

Anyone have any idea on how to proceed?

jonpedros
Posts: 2
Joined: Thu Aug 04, 2022 1:03 am

Re: pyboard v1.1 stuck at DFU mode?

Post by jonpedros » Wed Aug 17, 2022 1:56 am

Recently also tried cleaning the board with 99% isopropyl alcohol, but no go.

User avatar
jimmo
Posts: 2645
Joined: Tue Aug 08, 2017 1:57 am
Location: Sydney, Australia
Contact:

Re: pyboard v1.1 stuck at DFU mode?

Post by jimmo » Wed Aug 17, 2022 3:18 am

jonpedros wrote:
Thu Aug 04, 2022 1:17 am
Also tried connecting the 3V3 pin to the BOOT0 and pressing reset to go into DFU mode but no go.
When you do this, does Windows show any device connected (e.g. in Device Manager). What LEDs do you see on the board? Can you post a photo of the wiring you're using (just to make sure it's the right pin)

I think DfuSe is largely unmaintained these days. Maybe worth trying https://www.st.com/en/development-tools ... eprog.html

Post Reply