Factory reset problem

The official pyboard running MicroPython.
This is the reference design and main target board for MicroPython.
You can buy one at the store.
Target audience: Users with a pyboard.
User avatar
kamikaze
Posts: 127
Joined: Tue Aug 16, 2016 10:10 am
Location: СССР
Contact:

Factory reset problem

Postby kamikaze » Sun Jan 29, 2017 4:25 pm

Hi. I'm trying to factory reset my PyBoard by doing same steps as in this section

All is going ok until step 7. Red led doesn't turn on, filesystem is not being changed (checked with fsck also, it's ok).

Code: Select all

MicroPython v1.8.7-123-g0ddeedfc on 2017-01-29; PYBv1.1 with STM32F405RG

User avatar
kamikaze
Posts: 127
Joined: Tue Aug 16, 2016 10:10 am
Location: СССР
Contact:

Re: Factory reset problem

Postby kamikaze » Sun Jan 29, 2017 5:35 pm

Yep, something is broken. it is working with 3242cf2 commit. Also I have some import problems for the code that wasn't changed for a long time (also works with 3242cf2)

Issue: https://github.com/micropython/micropython/issues/2818

User avatar
dhylands
Posts: 2313
Joined: Mon Jan 06, 2014 6:08 pm
Location: Shuswap, BC, Canada
Contact:

Re: Factory reset problem

Postby dhylands » Sun Jan 29, 2017 8:41 pm

I can confirm this. Doing the factory reset doesn't reset anything. I also got a hard fault while running rshell, that went away as soon as I enabled hard fault detection.

In commit 4565d42, factory reset works.
In commit 3242cf2, factory reset still works.
In commit 84c614e, factory reset doesn't work.


Return to “The MicroPython pyboard”

Who is online

Users browsing this forum: No registered users and 2 guests