W5500 isconnected() False

The official pyboard running MicroPython.
This is the reference design and main target board for MicroPython.
You can buy one at the store.
Target audience: Users with a pyboard.
Post Reply
ulne
Posts: 3
Joined: Tue Jan 30, 2018 7:52 am
Location: Heidelberg

W5500 isconnected() False

Post by ulne » Tue Jan 30, 2018 11:11 am

I want to use the Pyboard 1.1
with a W5500 Board like this
(https://www.aliexpress.com/item/W5500-E ... 20397.html)

I connect the W5500 like this:
MOSI connected to X8
MISO connected to X7
SCLK connected to X6
nSS connected to X5
nRESET connected to X4

The Firmware ist the newest for network

The Pythoncode:

import network
nic = network.WIZNET5K(pyb.SPI(1), pyb.Pin.board.X5, pyb.Pin.board.X4)
print(nic.isconnected())

The export ist:
False

Thank you
Last edited by ulne on Thu Feb 01, 2018 6:25 am, edited 1 time in total.

cefn
Posts: 193
Joined: Tue Aug 09, 2016 10:58 am

Re: W5500 do not work

Post by cefn » Thu Feb 01, 2018 1:17 am

Hello and welcome to the Micropython Forum.

Unfortunately there's not much information in your post, describing for example...
* what you did in detail
* what you expected to happen
* what actually happened
* how you attempted to fix it

Sharing only "It don't work" makes it very hard for the community to identify what issue you are experiencing or resolve it.

I have often referred people to this reference document, which explains what makes a good bug report https://www.chiark.greenend.org.uk/~sgtatham/bugs.html

ulne
Posts: 3
Joined: Tue Jan 30, 2018 7:52 am
Location: Heidelberg

Re: W5500 isconnected() False

Post by ulne » Thu Feb 01, 2018 6:38 am

I want to use the Pyboard 1.1
with a W5500 Board like this
(https://www.aliexpress.com/item/W5500-E ... 20397.html)

I connect the W5500 like this:
MOSI connected to X8
MISO connected to X7
SCLK connected to X6
nSS connected to X5
nRESET connected to X4

The Firmware ist the newest for network

The Pythoncode:

import network
nic = network.WIZNET5K(pyb.SPI(1), pyb.Pin.board.X5, pyb.Pin.board.X4)
print(nic.isconnected())

The export ist:
False

Do the pyboard work with the W5500?
Thank you

Topaazy
Posts: 1
Joined: Mon Feb 12, 2018 12:28 pm
Location: https://bestazy.com

Re: W5500 isconnected() False

Post by Topaazy » Mon Feb 12, 2018 12:52 pm

Hey ulne,check out this topic.
I was looking for solutions to my problem on the forum, I came across yours.
May help. ;)
http://docs.micropython.org/en/v1.8.7/p ... twork.html
Regards Topazy.

ulne
Posts: 3
Joined: Tue Jan 30, 2018 7:52 am
Location: Heidelberg

Re: W5500 isconnected() False

Post by ulne » Tue Feb 13, 2018 9:31 am

Thank you Topaazy

I have connect my W5500 like your link

MOSI connected to X8
MISO connected to X7
SCLK connected to X6
nSS connected to X5 SCS on the W5500 Board
nRESET connected to X4 RST on the W5500 Board

like the class WIZNET5K

My Programm:
import network
nic = network.WIZNET5K(pyb.SPI(1), pyb.Pin.board.X5, pyb.Pin.board.X4)
print(nic.ifconfig())
print(nic.isconnected())

returns:
('0.0.0.0', '255.255.255.255', '0.0.0.0', '8.8.8.8')
False

Is the problem the inverted RESET and SS ??

best regards

Post Reply