network.CC3K makes REPL freeze

The official pyboard running MicroPython.
This is the reference design and main target board for MicroPython.
You can buy one at the store.
Target audience: Users with a pyboard.
Post Reply
User avatar
Posts: 3
Joined: Tue Mar 29, 2016 9:36 pm
Location: Montpellier, France

network.CC3K makes REPL freeze

Post by sebi » Mon Jan 07, 2019 9:09 pm

From a fresh start, every time I run the command
>>> nic = network.CC3K(pyb.SPI(2), pyb.Pin.board.Y5, pyb.Pin.board.Y4, pyb.Pin.board.Y3)
ՠ REPL freezes (it never returns).

I can type Ctrl+C TWICE to get back to the prompt.
If I run the network.CC3K command again I get an OSError: failed to init CC3000 module.

I tried initializing the pins low (especially VBEN) as suggested on the forum.
I tried adding some delay for VBEN being low as suggested on the forum.
I tried powering VIN with 5V instead of 3.3V as suggested on the forum.
I tried with a PYB v1.1 and a PYBLITE v1.0.
Nothing helped.

I remember that this command used to work for me in the past (maybe 3 years ago).
Currently I am using MicroPython v1.9.4 with the network drivers.

I also tried using my CC3000 module with an Arduino Uno.
I could initialize the module, access my local Wifi network, ping some websites, etc.
I even updated the CC3000 drivers using the Uno.
But it didn't help when switching back to a PyBoard...

Does anyone encountered such an issue and knows how to fix it?

Post Reply