pyBv1.1H does not show up on linux

The official pyboard running MicroPython.
This is the reference design and main target board for MicroPython.
You can buy one at the store.
Target audience: Users with a pyboard.
Post Reply
Terrill
Posts: 2
Joined: Thu Sep 05, 2019 5:32 pm

pyBv1.1H does not show up on linux

Post by Terrill » Thu Sep 05, 2019 6:01 pm

Just purchased and received my pyboard. Plugged it into linux Mint (ubuntu) saw a very brief green flash on the board but nothing shows up on screen. I have admin privileges on this machine. Did a "sudo lsblk" and again nothing is listed. Nothing also with "sudo lsusb". Checked with a volt meter and the boad reads 4.4 volts with 5.1 volts comming out of the usb cable. Also tried plugging into a Mac Book Pro also nothing shows up on screen. Also tried two different USB cables. This USB port mounts a usb thumb drive with no issues.
Held down the USR button and hit RST and the LEDs did sequence and tried different BOOT modes but still nothing on the screen?
Any suggestions?

User avatar
Roberthh
Posts: 1572
Joined: Sat May 09, 2015 4:13 pm
Location: Rhineland, Europe

Re: pyBv1.1H does not show up on linux

Post by Roberthh » Thu Sep 05, 2019 6:34 pm

Check if the USB cable you use has data wires. Quite a few time people used cables that are intended for charging only.

Terrill
Posts: 2
Joined: Thu Sep 05, 2019 5:32 pm

Re: pyBv1.1H does not show up on linux

Post by Terrill » Thu Sep 05, 2019 7:29 pm

Right you are, the third USB cable I tried worked and I see boot.py and main.py under PYBFLASH
Thank You

Post Reply