ESP8266 soft-reset after uos.uname()

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
Post Reply
federico
Posts: 29
Joined: Tue Feb 07, 2017 11:34 pm

ESP8266 soft-reset after uos.uname()

Post by federico » Mon Feb 13, 2017 8:37 pm

ESP8266 soft-reset after uos.uname()

Hardware:
a- RPiZero + ESP8266 pHAT
(RPi power supply from USB (LCD TV)
RPi HDMI to LCD TV HDMI )

b- microUSB RPi to 7 ports Manhattan USB Hub
c- Powerbank for power supply to USB Hub.

Software:
I start an REPL session with :
screen /dev/ttyACM0 115200

At the micropython prompt typing uos.uname() I have :
(sysname='esp8266', nodename='esp8266', release='2.0.0 (5a875ba)',
version='v1.8.7-7-gb5a1a203 on 2017-01-09', machine='ESPmodule with ESP8266)

I continue typing a lot of micropython command until I repeat

uos.uname() having the following different output with a soft-reset
(sysname='esp8266', nodename='esp8266', release= ets Jan 8 2013,
rst cause: 2, boot mode: (3,6)

and an ( in my opinion ) anomalous characters dump on the screen.

The REPL environment results blocked and I need to reboot the RPI to be able to open a new REPL session.

In the jpg attachments we have a visual description of the reset problem.
Thanks
Attachments
2_ESP8266_REPL_start_stop.jpg
2_ESP8266_REPL_start_stop.jpg (101.25 KiB) Viewed 1321 times
3_ESP8266_pHAT_RPi0.jpg
3_ESP8266_pHAT_RPi0.jpg (175.58 KiB) Viewed 1321 times

User avatar
dhylands
Posts: 3465
Joined: Mon Jan 06, 2014 6:08 pm
Location: Peachland, BC, Canada
Contact:

Re: ESP8266 soft-reset after uos.uname()

Post by dhylands » Mon Feb 13, 2017 8:44 pm

I believe that this was very recently fixed. See:
https://github.com/micropython/micropython/issues/2862

federico
Posts: 29
Joined: Tue Feb 07, 2017 11:34 pm

Re: ESP8266 soft-reset after uos.uname()

Post by federico » Mon Feb 13, 2017 10:49 pm

Many thanks, you are right.
I have update the firmware few days ago another after to have faced another problem
"
RPi_Pimoroni_ESP8266
Micropython firmware flashing
January 20 - 2017

with Pimoroni mp-flash-firmware.sh we have

( .....a blue light on the ESP8266 module flashing quickly during this process)

the blue light does not stop even if the mp-flash-firmware.sh command has completed its task. ( No error messages during the execution)

The REPL using the suggested command string with minicom give a quick characters dump on the terminal screen.
Also after a RPi's reboot the blue light quick flashing does not stop.

To verify hardware's failure I have reinstalled the original AT firmware using the at-flash-firmware.sh
command in Pimoroni/espiot-phat-master/firmware dir
and all is running properly with AT firmware.
( blue light stopped!!!)
Please let me know what's wrong in my procedure and if possible, give me some suggestion to solve the problem with micropython flashing.

Best regards
Federico Monaldi
esp8266-20170108-v1.8.7.bin (elf, map)
The problem is with this firmware - I have downloaded from the micropython official repository the firmware esp8266-20160809-v1.8.3.bin ( the one declared in Pimoroni flash-mp-firmware.sh ) and all the problems described in my previous email disappeared. At this point the problem is not in the Pimoroni ESP8266 pHAT.
"
that has been solved by Pimoroni Forum.
At this point I can only wait a new release .

Post Reply