Pathetic cry for help.

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
Post Reply
Posts: 2
Joined: Fri Jun 30, 2017 4:27 am

Pathetic cry for help.

Post by banda » Sat Jul 01, 2017 12:19 am

I live in beautiful New Zealand.
Is there anyone in NZ willing to flash my (or their) esp8266 module with MICROPYTHON for me?
I've tried for months, but I'm just not good enough.
There doesn't seem to be any pre-loaded ones available.
Any advice would be most appreciated.

User avatar
Posts: 33
Joined: Wed Oct 19, 2016 11:31 am
Location: Alsace, Europe

Re: Pathetic cry for help.

Post by ioukos » Mon Jul 03, 2017 11:14 am

Send it to France with an prestamped envelope. I'll make your install for you Kiwi, and I'll send it back to you.

More seriously you should give us some more details.

What have you tried so far ? what fails ? How do you know it fails ? Whats is your system, Linux, Windows ? Did you succeed to install Esptools ? etc...

PS: Where do you come from in New Zealand ?

Posts: 230
Joined: Tue Aug 09, 2016 10:58 am

Re: Pathetic cry for help.

Post by cefn » Thu Jul 06, 2017 11:22 am

I'm currently trying to work up a generic python-based script for retrieving and uploading micropython, based on ampy, esptool, pyserial. If you come back on this thread, it would be interesting to see if I can support you through using it, as well as your feedback improving the tool.

User avatar
Posts: 2052
Joined: Sat May 09, 2015 4:13 pm
Location: Rhineland, Europe

Re: Pathetic cry for help.

Post by Roberthh » Fri Jul 07, 2017 6:56 am

@banda, which kind of module are you trying to load?

User avatar
Posts: 453
Joined: Mon Jun 15, 2015 8:03 am

Re: Pathetic cry for help.

Post by mcauser » Sat Jul 08, 2017 12:15 am

On OSX, to install precompiled firmware, it's as simple as:

Code: Select all

brew install python wget screen
pip install --upgrade pip setuptools
pip install esptool
wget -p /dev/tty.wchusbserial1420 erase_flash -p /dev/tty.wchusbserial1420 write_flash -fm dio -fs 32m 0 esp8266-20170612-v1.9.1.bin
screen /dev/tty.wchusbserial1420 115200
Verbose version here: [url][/url]

Presuming you are using a Wemos D1 Mini ESP8266 board, which uses a CH340G USB-serial chip.
Driver here:

The /dev/tty.wchusbserial1420 is for the USB port on the right side of my MacBook and /dev/tty.wchusbserial1410 for the left USB port.
To find yours run:
ls /dev/tty*
If you don't see any, you need to install a driver for your boards USB-serial chip.

If you are using a different ESP8266 board which uses a CP210x chip, the driver can be found here: ... cp-drivers
The Wemos D1 Mini Pro uses one, and it shows up as /dev/tty.SLAB_USBtoUART on my MacBook

Or, next time your are in Australia (Sydney), I'll hook you up a few boards.

Post Reply