[nRF52832] REPL UART is not shown up

Discussion and questions about boards that can run MicroPython but don't have a dedicated forum.
Target audience: Everyone interested in running MicroPython on other hardware.
Post Reply
lnsri22
Posts: 68
Joined: Fri Aug 17, 2018 12:16 pm
Location: India

[nRF52832] REPL UART is not shown up

Post by lnsri22 » Fri Mar 08, 2019 5:36 am

Hello Everyone!!

After building the firmware successfully for nrf port , I could not see a REPL uart that is thrown by the device.

What could be the possible cause?

FYI

The command I'm issuing to make is

Code: Select all

make BOARD=pca10040 SD=s132 flash FROZEN_MPY_DIR=freeze
lnsri22 :)

c45713
Posts: 35
Joined: Fri Dec 09, 2016 7:09 pm

Re: [nRF52832] REPL UART is not shown up

Post by c45713 » Mon Mar 11, 2019 9:25 pm

Have you enabled the MICROPY_PY_BLE_NUS (1) in bluetooth_conf.h by mistake?
If so, this will route all UART REPL to BLE UART Service.

lnsri22
Posts: 68
Joined: Fri Aug 17, 2018 12:16 pm
Location: India

Re: [nRF52832] REPL UART is not shown up

Post by lnsri22 » Thu Mar 14, 2019 5:26 am

Hello c45713,

Thank you so much for the quick reply there!!

I have not enabled it in the config file.

Tried to attach a screenshot. But could not do due to technical problem with uploading attachment
lnsri22 :)

c45713
Posts: 35
Joined: Fri Dec 09, 2016 7:09 pm

Re: [nRF52832] REPL UART is not shown up

Post by c45713 » Fri Mar 15, 2019 9:47 pm

I have not enabled it in the config file.
Great. Then that is not an issue.

Could you make sure that you are starting fresh on the pca10040 by issuing the following sequence:

Code: Select all

nrfjprog --eraseall -f nrf52
make BOARD=pca10040 SD=s132 clean
make BOARD=pca10040 SD=s132 
make BOARD=pca10040 SD=s132 sd
make BOARD=pca10040 SD=s132 flash 
Does this work any better?

lnsri22
Posts: 68
Joined: Fri Aug 17, 2018 12:16 pm
Location: India

Re: [nRF52832] REPL UART is not shown up

Post by lnsri22 » Tue Mar 19, 2019 5:05 am

Thanks again c45713!!

Let me give it a try and update you!!
lnsri22 :)

knowic
Posts: 5
Joined: Thu Aug 15, 2019 7:49 am

Re: [nRF52832] REPL UART is not shown up

Post by knowic » Fri Aug 16, 2019 4:45 pm

Hello, sir,

Have you get your issue fixed now? I have the same questions.

thanks .
Jason Hu

Post Reply