not work upip.install("micropython-sqlite3")

Discussion about programs, libraries and tools that work with MicroPython. Mostly these are provided by a third party.
Target audience: All users and developers of MicroPython.
Post Reply
mehdi_ziyaei
Posts: 16
Joined: Tue May 21, 2019 5:58 pm

not work upip.install("micropython-sqlite3")

Post by mehdi_ziyaei » Tue May 21, 2019 6:11 pm

i want to use database in nodemcu ESP8266
i want install sqlite or mysql lib to my nodemcu

i'm use code :
import upip
upip.install("micropython-sqlite3")



but after a one hour in my nodemcu :
MicroPython v1.10-8-g8b7039d7d on 2019-01-26; ESP module with ESP8266
Type "help()" for more information.
>>>
paste mode; Ctrl-C to cancel, Ctrl-D to finish
=== import upip
=== upip.install("micropython-sqlite3")
===
Installing to: /lib/





------------------------------------------
https://imgur.com/cBTnHp4


i want use sqlite or mysql on nodemcu.how use ? how install lib ? how how how ?? tnx

User avatar
Roberthh
Posts: 2441
Joined: Sat May 09, 2015 4:13 pm
Location: Rhineland, Europe

Re: not work upip.install("micropython-sqlite3")

Post by Roberthh » Tue May 21, 2019 6:20 pm

micropython-sqlite3 will not work on the nodemcu. It is made for the Linux version of Micropython and requires libsqlite3.

mehdi_ziyaei
Posts: 16
Joined: Tue May 21, 2019 5:58 pm

Re: not work upip.install("micropython-sqlite3")

Post by mehdi_ziyaei » Tue May 21, 2019 6:29 pm

hi
What is your offer? What method do I use? To access the database.

User avatar
Roberthh
Posts: 2441
Joined: Sat May 09, 2015 4:13 pm
Location: Rhineland, Europe

Re: not work upip.install("micropython-sqlite3")

Post by Roberthh » Tue May 21, 2019 6:35 pm

The standard firmware of the ESP8266 include a small database called btree. Please consult the internet and the documentation on how to use that. Maybe it suits your needs.

mehdi_ziyaei
Posts: 16
Joined: Tue May 21, 2019 5:58 pm

Re: not work upip.install("micropython-sqlite3")

Post by mehdi_ziyaei » Tue May 21, 2019 6:43 pm

tnx for your comment .
but btree is not usefull for me .
i want to use mysql or sqlite .
Which operating system for this device supports these databases libs?

User avatar
Roberthh
Posts: 2441
Joined: Sat May 09, 2015 4:13 pm
Location: Rhineland, Europe

Re: not work upip.install("micropython-sqlite3")

Post by Roberthh » Tue May 21, 2019 6:49 pm

I do not know, and my expectation is, that there is none. There is even no operating system for the ESP8266 besides the RTOS, which is used by MicroPython. But that is not OS like Linux or the like. If you need an operating system and software like sqlite3, better use the RPI class of device.

Post Reply