Not working with my Lol1n/esp8266mod board

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
Post Reply
Posts: 26
Joined: Sat Jun 22, 2019 6:07 am

Not working with my Lol1n/esp8266mod board

Post by misaalanshori » Sat Jun 22, 2019 6:59 am

I flashed it with this command

hello@hello-there:~$ sudo esptool --port /dev/ttyUSB0 --baud 115200 write_flash --flash_size=detect 0 esp8266-20190529-v1.11.bin v2.5.1
Serial port /dev/ttyUSB0
Detecting chip type... ESP8266
Chip is ESP8266EX
Features: WiFi
MAC: a0:20:a6:13:a9:db
Enabling default SPI flash mode...
Configuring flash size...
Auto-detected Flash size: 4MB
Erasing flash...
Flash params set to 0x0040
Took 2.63s to erase flash block
Wrote 618496 bytes at 0x00000000 in 62.7 seconds (79.0 kbit/s)...

Hard resetting via RTS pin...

But there is no output in serial monitor..
using mode DIO seems to cause it to reset loop:

ets Jan 8 2013,rst cause:2, boot mode:(3,6)

load 0x40100000, len 31024, room 16
tail 0
chksum 0xb4
load 0x3ffe8000, len 1104, room 8
tail 8
chksum 0x74
load 0x3ffe8450, len 824, room 0
tail 8
chksum 0x45
csum 0x45
rf_cal[0] !=0x05,is 0x00

(this repeats until its unplugged)

I don't think my board is broken because i have tried with 2 boards with the same result and flashing another firmware works (tested with spacehuhn deauther)

Post Reply