Newbie: pyboard 1.1 does not work after a firmware update

The official pyboard running MicroPython.
This is the reference design and main target board for MicroPython.
You can buy one at the store.
Target audience: Users with a pyboard.
Post Reply
psereni
Posts: 2
Joined: Wed Sep 11, 2019 8:06 am

Newbie: pyboard 1.1 does not work after a firmware update

Post by psereni » Wed Sep 11, 2019 8:24 am

Hi,
I have two pyboards 1.1.
for one of them I performed a firmware update as described by O'reilly programming with micropython, i.e. I downloaded the latest pybv11-20190911-v.11***.dfu file and I used the command
$sudo dfu-util --alt 0 pybv11*.dfu

The update process worked apparently ok, but the files are all unreadable and I got a mounting error

REPL seems to work, but the connection starts with errors "file "boot.py", lin1, in <module> NameError: name...... is not defined
and the same for "main.py"....

Thank you for any help

Paolo

User avatar
Roberthh
Posts: 1568
Joined: Sat May 09, 2015 4:13 pm
Location: Rhineland, Europe

Re: Newbie: pyboard 1.1 does not work after a firmware update

Post by Roberthh » Wed Sep 11, 2019 8:35 am

It looks like the file system was damaged. To recreate it, follow the instructions here for boot mode 3:
http://docs.micropython.org/en/latest/p ... boot-modes

psereni
Posts: 2
Joined: Wed Sep 11, 2019 8:06 am

Re: Newbie: pyboard 1.1 does not work after a firmware update

Post by psereni » Wed Sep 11, 2019 8:53 am

Thank you. This was the right thing to do. :)

Post Reply