issues observed reset/power up

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
Post Reply
Posts: 13
Joined: Fri Jan 20, 2017 3:35 pm

issues observed reset/power up

Post by mmh » Sun Jan 29, 2017 2:36 am

[SOLVED] this boot issue is a user error, It has to do with my connection being cooked (argh) I will go verify but if I boot unconnected to a terminal program it works just fine.

Multiple resets don't end up booting parts correctly on the tip of the tree. A clean boot is successful about 33% of the time, Over the past few days I have noticed the a weird behavior on boot where both my ESP-01 and lua board don't successfully boot. I passed it off as something I was doing wrong which I still might be. I'm starting a discussion to help learn how to debug such issues and see if others in the group are observing the same issue.

When things boot properly I get the >>> and when they don't I get a stream of random bytes over the TX (I'm sure they mean something) seems like no RX.

Do folks use gdb or something like that to debug these low level issues or something else?

Also on the latest version I noticed that webrepl once installed causes my system to go into a inf-loop printing rubbish trying to read something associated to vfat.

This is on a clean pull/build and for me the build is and maybe this is just wrong, just a plain old make in the esp8266 directory.

[SOLVED] I believe this is related to /flash/ instead of /, I found a similar problem in mpfshell and posted a patch here:

<<<--excerpt from webrepl loop --->>>

Code: Select all

l��r��  yr�'b����8�p�lp�������p�lll��r��        yr�'b��lb��p��p�������8��cl`���������rn�������l��b���b������b��bl`�<��8�ǒ���?b���l��l`�>r�x��l`#�r����8����r�����8�����lrr��9l�Ğb����b��b��lx�쎛�xb��8~�n���N������l������l`>`�ܒ��b��l�8�������|�rrr�nĒ���|�� l��������l8������bn��n���H`lb������lx������bl`��������rn����l�p�p������b�$�l���#��l`��l{��l��r���#5 ets_task(40100164, 3, 3fff8298, 4)
WebREPL daemon started on ws://
WebREPL daemon started on ws://
Started webrepl in normal mode

 ets Jan  8 2013,rst cause:2, boot mode:(3,6)

load 0x40100000, len 32196, room 16 
tail 4
chksum 0xc2
load 0x3ffe8000, len 1104, room 4 
tail 12
chksum 0xfd
ho 0 tail 12 room 4
load 0x3ffe8450, len 3000, room 12 
tail 12
chksum 0x48
csum 0x48

Post Reply