Flashing the D1 Mini Lite

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
User avatar
bandaangosta
Posts: 6
Joined: Thu May 18, 2017 1:39 pm
Location: Santiago, Chile
Contact:

Re: Flashing the D1 Mini Lite

Post by bandaangosta » Fri May 19, 2017 12:38 am

Thanks for all the good info here.
I was facing a similar issue where I could correctly flash the firmware (thanks for the tip, deshipu), but could not load any python scripts onto boards Wemos D1 Mini Lite or D1 Mini v2.20. Meanwhile, the D1 Mini Pro worked fine. ampy would hang without any output.
At some point, trying to isolate involved variables, I tried the ampy script within a virtualenv environment. It worked!
Back to the global system libraries, it turned out that although ampy was up to date, one of its dependencies was not (but still satisfying ampy's requirement): pyserial. I had version 2.6 and updated to 3.3.
So, in summary, everything worked fine after running:

sudo pip install --upgrade pyserial

gregor
Posts: 1
Joined: Thu Jun 22, 2017 2:47 am

Re: Flashing the D1 Mini Lite

Post by gregor » Thu Jun 22, 2017 2:51 am

I have the same issue as reported by user "devnull"

esptool.py --port /dev/tty.wchusbserial1440 --baud 115200 write_flash --flash_mode=dout --flash_size=detect 0 esp8266-20170108-v1.8.7.bin

ampy --port /dev/tty.wchusbserial1440 put n.py n.py

results in

ampy.pyboard.PyboardError: could not enter raw repl

Is there an updated image available that does not include thsi error. THis is for D1 Mini

User avatar
Roberthh
Posts: 2052
Joined: Sat May 09, 2015 4:13 pm
Location: Rhineland, Europe

Re: Flashing the D1 Mini Lite

Post by Roberthh » Thu Jun 22, 2017 6:54 pm

If you open a serial terminal connection to the board, e.g. with screen, can you enter raw REPL mode manually with Ctrl-A?

Post Reply