WLAN.config(hidden="False") didnt work

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
Post Reply
ZKDMun
Posts: 38
Joined: Thu Nov 24, 2016 2:34 pm
Location: Hamburg

WLAN.config(hidden="False") didnt work

Post by ZKDMun » Thu Jun 14, 2018 4:49 pm

MicroPython-Version: "MicroPython v1.9.3-8-g63826ac5c on 2017-11-01"

Hi there,
I have changed the WLAN config last time to WLAN.config(hidden="True") - but now I am not able to reverse this.

I have tried:

Code: Select all

WLAN.config(hidden="False")
But after this I will always get:

Code: Select all

WLAN.config("hidden")
>>> True
I have tried hard reset too - without success.

Any idea how to solve this?

Another problem:
If my essid is hidden, I cannot connect my second board to this one...
I have tried this on my ESP32 - there it is possible to connect with it, if the essid is hidden. But on the ESP8266 this didnt work? :(


edit:
same problem with "esp8266-20180511-v1.9.4".

ZKDMun
Posts: 38
Joined: Thu Nov 24, 2016 2:34 pm
Location: Hamburg

Re: WLAN.config(hidden="False") didnt work

Post by ZKDMun » Thu Jun 14, 2018 5:14 pm

Found the solution:

You can set WLAN.config(hidden="True") or WLAN.config(hidden=True) - both works.

But you have to use WLAN.config(hidden=False) to reverse this... WLAN.config(hidden="False") didnt work.
Inserting the boolean False as a string didnt work, just for setting it "True".

And connecting to the other board just need a few seconds... than WLAN.isconnected() returns True.
Sorry for time stealing :(

Post Reply