esptool cannot connect to HiLetgo® ESP-WROOM-32

All ESP32 boards running MicroPython.
Target audience: MicroPython users with an ESP32 board.
Post Reply
Posts: 3
Joined: Sat Jul 07, 2018 2:42 pm

esptool cannot connect to HiLetgo® ESP-WROOM-32

Post by lamikam » Sat Jul 07, 2018 2:47 pm

Just got the board. When I connect to it through usb/serial terminal app, on board startup, it appears to continually be scanning for wifi points:

scan start
scan done
2 networks found
1: Nobody Close (-49)*
2: Nobody Close_2GEXT (-74)*

This never seems to end. When I try to erase the flash with esptool: --chip esp32 --port COM3 --baud 115200 erase_flash

just get a timeout eventually. Any suggestion

Posts: 28
Joined: Wed Mar 30, 2016 4:09 pm

Re: esptool cannot connect to HiLetgo® ESP-WROOM-32

Post by yeyeto2788 » Thu Jul 19, 2018 1:44 pm

Hello @lamikan,

I guess that the problem you're having is the baud rate you're to connect to the board, as I can see you are trying with

Code: Select all

please try with

Code: Select all --chip esp32 --port <your device port> --baud 460800  erase_flash

Another thing I strongly recommend is upgrade the esptool if you haven't done it yet.

I tried the command I post above with the esptool v2.4.1 and it worked like a charm.

Hope it helps


User avatar
Posts: 141
Joined: Tue Oct 17, 2017 5:18 am

Re: esptool cannot connect to HiLetgo® ESP-WROOM-32

Post by liudr » Tue Jul 31, 2018 2:37 am

Can you provide a link to the board you purchased? If nothing works, maybe we can look at the sales page and find a circuit diagram. Sometimes it could be the manufacturing wasn't perfect and you have a few disconnected pins. Does your board look good on closeup inspection?

Post Reply