Sonoff S20 does not boot when powered on AC

Discussion and questions about boards that can run MicroPython but don't have a dedicated forum.
Target audience: Everyone interested in running MicroPython on other hardware.
Post Reply
Pivert
Posts: 1
Joined: Fri Aug 10, 2018 1:00 pm

Sonoff S20 does not boot when powered on AC

Post by Pivert » Fri Aug 10, 2018 9:10 pm

Hi,

I have a strange behaviour. The Sonoff S20 works properly when powered with the USB Serial adapter with 3.3V adapter.
But when I plug it to the AC, nothing happens.
It's like the boot.py and/or main.py are blocked.

Could it be because of the Serial adapter is disconnected ?
(P.S.: I never risked to plug both AC and USB adapter, since there might be risks for the PC).

User avatar
pythoncoder
Posts: 2799
Joined: Fri Jul 18, 2014 8:01 am
Location: UK
Contact:

Re: Sonoff S20 does not boot when powered on AC

Post by pythoncoder » Sun Aug 12, 2018 6:08 am

I haven't used the S20 but I spent a lot of time trying to get reliable operation out of a Sonoff Basic. I failed, with the outcome described here.

The device did have proper isolation: you could run the serial port with the device powered from AC. It would also start properly with no serial connection. However as described in the above link my eventual conclusion was that these devices are useless, at least when running MicroPython. I'll be interested to hear if the S20 is any better.

The S20 may or may not have proper isolation.

If you have a test meter you can check for isolation by measuring resistance on a high range between the serial 0V line and each of the pins of the power plug connector. There should be infinite resistance between serial 0V and the Live and Neutral pins. Low resistance to Earth is allowable, but the units I used had complete isolation. If you're not confident doing this then don't take risks: working on kit carrying live AC mains requires some skill and care.
Peter Hinch

Post Reply