install earlier version of lib

All ESP32 boards running MicroPython.
Target audience: MicroPython users with an ESP32 board.
Post Reply
amirfh
Posts: 2
Joined: Sun Nov 18, 2018 10:34 pm

install earlier version of lib

Post by amirfh » Wed Dec 26, 2018 12:07 am

How to install specific version of lib , i got this message when try to install logging lib :

>>> import upip
>>> upip.install('micropython-logging==0.4.1')
Installing to: /lib/
Warning: pypi.org SSL certificate is not validated
Error installing 'micropython-logging==0.4.1': Package not found, packages may be partially installed

User avatar
mattyt
Posts: 190
Joined: Mon Jan 23, 2017 6:39 am

Re: install earlier version of lib

Post by mattyt » Sun Jan 06, 2019 7:52 am

Currently upip can only install the latest version of a package. See upip.py:175.

I'll try and raise a pull request to allow different versions to be installed.

In the meantime the workaround is to simply download the library you require and copy the files to your device.

Post Reply