Power consumption of TTGO T8 Board

All ESP32 boards running MicroPython.
Target audience: MicroPython users with an ESP32 board.
Online
ThomasChr
Posts: 107
Joined: Sat Nov 25, 2017 7:50 am

Power consumption of TTGO T8 Board

Post by ThomasChr » Fri May 17, 2019 8:46 pm

Hello Forum,

I‘ve got a TTGO T8 v1.7 Board, details can be found on Github https://github.com/LilyGO/TTGO-T8-ESP32 and I‘ve attached the schematics. The board can be powered by a Battery and this battery does only provide the 3.3V rail. Seems pretty right to me!

But when I use machine.deepsleep() and provide power via the battery the consumption only goes down to 3.5 mA. I‘ve desoldered the SIL2104 Usb/serial chip which is on the 3.3V rail and got it down to 3.1 mA. But thats still way to high. Has anyone any clues what is wrong here?
Is it the crystal? Or a cheap 3.3V regulator?
The spiram and flash seems to be powered by the ESP and I assume they got powered down in deepsleep. I‘m just curios what is eating that much power away and any help on this will be greatly appreciated!

Thomas
Attachments
Schematic.zip
(96.6 KiB) Downloaded 4 times

User avatar
jimmo
Posts: 84
Joined: Tue Aug 08, 2017 1:57 am

Re: Power consumption of TTGO T8 Board

Post by jimmo » Sat May 18, 2019 12:56 am

What's your setup for measuring the current?

Are you able to verify with a multimeter that VDD_SDIO is in fact being turned off in deep sleep?

The regulator is a buck converter... the datasheet doesn't give a good indication of what its low-load current is like but of course the efficiency does drop at lower output currents.

Online
ThomasChr
Posts: 107
Joined: Sat Nov 25, 2017 7:50 am

Re: Power consumption of TTGO T8 Board

Post by ThomasChr » Sat May 18, 2019 5:41 am

Hi jimmo,

thanks for your help!

This is the code I use, maybe I can switch something of in the Code?

Code: Select all

import time
import machine

led = machine.Pin(21, machine.Pin.OUT)

while True:
   # 30 Secs blink
   for i in range (0, 15):
       time.sleep(1)
       led.value(1)
       time.sleep(1)
       led.value(0)
   
   # 30 secs deepsleep
   machine.deepsleep(30000)
I‘m measuring the current flowing from the battery (my lab bench power supply) at 4V with Dave Jones uCurrent. I noticed that decreasing the Voltage reduces the power consumption clearly and thought that this must be a not very efficent power regulator. (out of my head the numbers are something like 0.5 less mA if you reduce the power by 0.5V - the drop seems to be fairly linear so I don‘t think it‘s some kind of brownout)

I will measure VDD_SDIO tomorrow when I‘m back at home, a good idea. I have no problem with damaging the board if that is needed to satisfy my curiosity.

I also will post the exact consumption at 4V, 3.8V and 3.5V - without the SIL2104.

Thank you very much so far!

Thomas

Online
ThomasChr
Posts: 107
Joined: Sat Nov 25, 2017 7:50 am

Re: Power consumption of TTGO T8 Board

Post by ThomasChr » Sun May 19, 2019 7:08 pm

VDD_SDIO is not pulled low when entering deepsleep. So flash and psram aber active in deepsleep. Any ideas how I could change that?

Online
ThomasChr
Posts: 107
Joined: Sat Nov 25, 2017 7:50 am

Re: Power consumption of TTGO T8 Board

Post by ThomasChr » Mon May 20, 2019 7:13 pm

Some news here:
1. VDD_SDIO does not go low when entering deepsleep. It seems that the Resistor R20 is placed on the board and pulling VDD_SDIO to 3.3V. Removing it helped and I lost one more mA (1.5 mA total in deepsleep)
2. I powered the board directly on the 3.3V rail, so the SYS8008B Voltage regulator was not involved and I'm down to 295 µA.

So still there are some 280 µA to catch. Anyone got an idea what I can try now?
Of course, everything is allowed, even experiments which will destroy the board, all to satisfy my curiosity!

Thomas

Online
ThomasChr
Posts: 107
Joined: Sat Nov 25, 2017 7:50 am

Re: Power consumption of TTGO T8 Board

Post by ThomasChr » Mon May 20, 2019 7:34 pm

Maybe it‘s a Pullup Resistor burning power? But I‘m not sure which one... I‘m assuming the GPIOS of the ESP32 are floating in deepsleep and so not sourcing any current to a pullup resistor like R14 which is pulling GPIO12 high.

User avatar
Roberthh
Posts: 1367
Joined: Sat May 09, 2015 4:13 pm
Location: Rhineland, Europe

Re: Power consumption of TTGO T8 Board

Post by Roberthh » Mon May 20, 2019 8:05 pm

Even if you source by 3.3V, the power regulator is still connected at it's output.

Online
ThomasChr
Posts: 107
Joined: Sat Nov 25, 2017 7:50 am

Re: Power consumption of TTGO T8 Board

Post by ThomasChr » Mon May 20, 2019 8:19 pm

So blowing the power IC off the board could help?

User avatar
Roberthh
Posts: 1367
Joined: Sat May 09, 2015 4:13 pm
Location: Rhineland, Europe

Re: Power consumption of TTGO T8 Board

Post by Roberthh » Mon May 20, 2019 8:34 pm

Hard to say. I do not know the internals of that chip, and the data sheet does not tell much about reverse sourcing.

Online
ThomasChr
Posts: 107
Joined: Sat Nov 25, 2017 7:50 am

Re: Power consumption of TTGO T8 Board

Post by ThomasChr » Mon May 20, 2019 8:35 pm

I‘ll try it tomorrow and will report the outcome here!

Post Reply