Porting to STM32L476Discovery/LimiFrog

Discussion and questions about boards that can run MicroPython but don't have a dedicated forum.
Target audience: Everyone interested in running MicroPython on other hardware.
User avatar
marfis
Posts: 197
Joined: Fri Oct 31, 2014 10:29 am
Location: Zurich / Switzerland

Re: Porting to STM32L476Discovery/LimiFrog

Post by marfis » Fri Oct 28, 2016 7:00 pm

badi wrote:I wrote some very simple drivers for the sensors on limifrog board which are available here:
https://github.com/tobbad/limifrog
I maybe convert them to a more micropythonic style.
@badi: this link appears to be broken - is there an alternative one?

User avatar
badi
Posts: 51
Joined: Mon Aug 10, 2015 2:18 pm
Location: Bern, Switzerland

Re: Porting to STM32L476Discovery/LimiFrog

Post by badi » Sat Oct 29, 2016 12:14 pm

I moved the stuff in a new, more general repo:
https://github.com/tobbad/micropython_lib
badi

User avatar
marfis
Posts: 197
Joined: Fri Oct 31, 2014 10:29 am
Location: Zurich / Switzerland

Re: Porting to STM32L476Discovery/LimiFrog

Post by marfis » Mon Oct 31, 2016 8:23 pm

Thanks for the update.

Regarding firmware update on the limifrog:
I was wondering if you managed to download the firmware via USB DFU (instead of taking the ST-link debugger)? I haven't seen it mentioned in the docs.

Since BOOT0 is wired to switch3 I think it should be possible, but I didn't succeed to put the board in dfu mode... What I've tried was to press switch3 and then plugin the USB connector.

User avatar
marfis
Posts: 197
Joined: Fri Oct 31, 2014 10:29 am
Location: Zurich / Switzerland

Re: Porting to STM32L476Discovery/LimiFrog

Post by marfis » Mon Oct 31, 2016 8:37 pm

ok, sorry - I stumbled across this:
https://github.com/LimiFrog/LimiFrog-SW ... mifrog.pdf

I'll give it a try then!

danielm
Posts: 167
Joined: Mon Oct 05, 2015 12:24 pm

Re: Porting to STM32L476Discovery/LimiFrog

Post by danielm » Wed Nov 09, 2016 10:01 pm

I just found out that this Moto Mod devkit for Lenovo Moto Z smartphones uses L476:
https://developer.motorola.com/build/mdk-user-guide

https://www.youtube.com/watch?v=HLSLrzmcXGM&t=185s

What changes needs to be done to your port to make it running on that devkit?

Post Reply