Repl not Responding

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
Post Reply
Posts: 1
Joined: Mon Jun 11, 2018 3:33 pm

Repl not Responding

Post by andrea » Mon Jun 11, 2018 4:09 pm

I had some Problems when I tried to flash Micropython on my board (NodeMCU Lua Amica V2).
This seems to be happening often, but I still didn't find any post helping me.
I erased the flash and rewrote it without any Problems. I pressed the RST pin and tried to start a REPL to enter Code, but it wasn't working at all. First I tried Picocom then Minicom, they both didn't let me type anything into the REPL, also they don't show ">>>" at the beginning as they did when I was using the repl on the pyboard.
Then I tried to use RShell and entered the repl. I was able to type this time but still no ">>>" and no response from the board.
I tried to connect from a Laptop with Antergos Linux installed and from my Raspberry with Raspian.
I also tried various builts of Micropython (including the 512 version, even though flash_id tells me he has 4MB)

I hope someone has any idea, what could have went wrong :/

User avatar
Posts: 3497
Joined: Fri Jul 18, 2014 8:01 am
Location: UK

Re: Repl not Responding

Post by pythoncoder » Wed Jun 13, 2018 7:25 am

As far as I'm concerned rshell is the gold standard for communications with MicroPython targets: if it doesn't work, the target is at fault.

So I suspect your esptool invocation doesn't match your hardware. Have you tried the -fm dio option as recommended in the docs? How current is your Mine is v2.1-beta1.

I suggest you post your esptool invocation line. There is a -verify_flash option which should provide some feedback on success or failure. I use

Code: Select all --port /dev/ttyUSB0 --baud 115200 write_flash --verify --flash_size=detect -fm dio 0 build/firmware-combined.bin
If you're using pre-built firmware you'll need to adapt the last part of the line to point to your firmware.bin file.
Peter Hinch

Posts: 225
Joined: Tue Aug 09, 2016 10:58 am

Re: Repl not Responding

Post by cefn » Wed Jun 13, 2018 8:27 pm

There's a reasonable chance that if you download install vgkits-vanguard ( ) that you can simply run...

Code: Select all

vanguard brainwash micropython
vanguard shell
...and the first line will install 1.9.4 Micropython, and the second will launch a terminal.

Let me know how you get on.

Posts: 3
Joined: Thu Jul 19, 2018 5:11 pm

Re: Repl not Responding

Post by chromecat » Thu Jul 19, 2018 8:59 pm

Got the same problem.

tried it also with vanguard brainwash micropyhton
>> Device doesn't match known flashing configuration

and stops after erasing flash.

Posts: 225
Joined: Tue Aug 09, 2016 10:58 am

Re: Repl not Responding

Post by cefn » Fri Jul 20, 2018 11:27 pm

Hi, Chromecat

What board are you using with vanguard? Can you copy paste from the terminal session so we can see more precisely what is being typed and the result. The command you shared has 'micropython' mistyped, for example. I may have a matching board I can test against.

Posts: 56
Joined: Sat Apr 21, 2018 5:02 am

Re: Repl not Responding

Post by cyberlab » Sun Jul 22, 2018 4:30 am

Hello if you are in windows enviroment, replace COM5 for de com port number of your nodemcu: --port COM5 erase_flash

Again replace COM5 and esp8266.bin for your COM port number and esp8266 binary file of your choice: --port COM5 --baud 460800 write_flash --flash_size=detect -fm dio 0 esp8266-20180722-v1.9.4-403-g81e320aec.bin

I use upyloader works great for my, from betaRavener, download windows version:

In upyloader program: in connection: (select the com port of your nodemcu)
Click in: (connect)
if everithing is ok until now is going to show up a warning window:(transfer scripts problem) click ok.
in File select:Init transfer Files, after that in view you can open a terminal window and you will see the >>>.
in main window you can transfer files back and forward to your nodemcu, you can connect by wifi and many other useful things!

Posts: 42
Joined: Sun Aug 06, 2017 12:55 pm
Location: Germany

Re: Repl not Responding

Post by crizeo » Tue Mar 19, 2019 10:15 pm

Just for those coming across this post: I had the same problem, checked my setup (bare ESP8266 module) 100+ times and it definitely was correct. I could flash the ESP most of the times, but could not connect afterwards. Problem had something to do with my breadboard/wiring; bad junctions (maybe because of dirt/glue). Did the exact same wiring on another board with cleaned resistors, now it works.

Post Reply