Cant access REPL

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
Post Reply
Posts: 4
Joined: Thu Jul 19, 2018 5:11 pm

Cant access REPL

Post by chromecat » Thu Jul 19, 2018 5:19 pm

I bought two lolin NodeMcu board and tried to install everything correctly..
when i flashed it and want to access the repl there are just symbols like shown below.


i did everything like ... intro.html

i got mac os x and tried it also on windows with both boards.
When i try it with webrepl it instantly disconnect.

Anyone got the same issue ?

update: tried it with esplorer as nodemcu firmware and also got these kind of symbols as response

User avatar
Posts: 61
Joined: Tue Nov 14, 2017 3:11 am
Location: Perth, Australia

Re: Cant access REPL

Post by philwilkinson40 » Fri Jul 20, 2018 3:57 am

OK @chromecat step by step:
1) when you installed the firmware using what message was displayed in the Terminal? Did you erase_flash first before you write flash the firmware? What speed (baudrate) did you use? Try it at 115200.
2) How are you trying to access REPL? Using PUTTY on Windows? In PUTTY what are you Category Serial Connection settings? Double check you are using the correct COM port and the speed (baudrate) is 115200, 'Flow Control' is set to 'None'

Posts: 4
Joined: Thu Jul 19, 2018 5:11 pm

Re: Cant access REPL

Post by chromecat » Fri Jul 20, 2018 2:59 pm

yes i did erased the flash bevor.
i tried every baudrate 9600-115200 --port /dev/cu.wchusbserial1410 --baud 57600 write_flash --flash_size=detect 0 esp8266-20170108-v1.8.7.bin v2.5.0
Serial port /dev/cu.wchusbserial1410
Detecting chip type... ESP8266
Chip is ESP8266EX
Features: WiFi
MAC: bc:dd:c2:fe:72:15
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Auto-detected Flash size: 4MB
Flash params set to 0x0040
Compressed 586700 bytes to 381924...
Wrote 586700 bytes (381924 compressed) at 0x00000000 in 67.6 seconds (effective 69.5 kbit/s)...
Hash of data verified.

Hard resetting via RTS pin...

thats the output from terminal.
I tried to access via screen on mac os x, when used Putty port. baudrate, flow control etc seems right

User avatar
Posts: 4917
Joined: Fri Jul 18, 2014 8:01 am
Location: UK

Re: Cant access REPL

Post by pythoncoder » Mon Jul 23, 2018 4:26 am

I appreciate this doesn't fix your problem, but your invocation line (with only the USB device changed for my system) works here on the reference board. I suspect you may have terminal problems (baudrate, bits per char, parity, flow control).

Incidentally why are you flashing an old build? The latest release build is v1.9.4.
Peter Hinch

Post Reply