New Lolin D32 Pro with 4MB PSRAM

All ESP32 boards running MicroPython.
Target audience: MicroPython users with an ESP32 board.
User avatar
Roberthh
Posts: 1699
Joined: Sat May 09, 2015 4:13 pm
Location: Rhineland, Europe

Re: New Lolin D32 Pro with 4MB PSRAM

Post by Roberthh » Fri Sep 21, 2018 8:08 pm

I do not have a D32 Pro at hand, so the setting of the Pins was derived from the d32 specs. But they should be OK, since the software SPI works. With the Lolin32 pro I have sometimes the issue that I have to do a hard reset with the SD card inserted to get it properly working.

And no, SPI and serial port are independent, unless you assign them to the same Pins.

ARTaylor
Posts: 29
Joined: Fri Mar 23, 2018 4:04 pm
Contact:

Re: New Lolin D32 Pro with 4MB PSRAM

Post by ARTaylor » Sun Sep 23, 2018 11:25 am

Roberthh wrote:
Fri Sep 21, 2018 8:08 pm
I do not have a D32 Pro at hand, so the setting of the Pins was derived from the d32 specs. But they should be OK, since the software SPI works. With the Lolin32 pro I have sometimes the issue that I have to do a hard reset with the SD card inserted to get it properly working.

And no, SPI and serial port are independent, unless you assign them to the same Pins.
The pins are good - I was able to talk to the micro SD with software SPI but no luck with hardware. I will do some more testing this evening. It would be good to get SD access baked into the ESP32 port I think.
Grow something!

User avatar
philwilkinson40
Posts: 59
Joined: Tue Nov 14, 2017 3:11 am
Location: Perth, Australia

Re: New Lolin D32 Pro with 4MB PSRAM

Post by philwilkinson40 » Fri Oct 19, 2018 12:59 am

Has anyone had problems with the LiPo connection on D32Pro? I have been running along fine with USB serial power.
I get a decent reading at the battery terminals on the board, but nothing further in. Even VBAT has nothing ?!? I have a Lolin32 Pro V1.0.0 (with apparently the same battery circuit) which runs fine off a LiPo.
I can't find any known problems on the ESP32/wemos forums. Has anyone else experienced this problem?
batcircuit.gif
batcircuit.gif (11.1 KiB) Viewed 1030 times

wr300000
Posts: 22
Joined: Sun Jan 14, 2018 3:54 pm

Re: New Lolin D32 Pro with 4MB PSRAM

Post by wr300000 » Sat Dec 15, 2018 8:52 am

Roberthh wrote:
Sun Sep 16, 2018 9:31 am
I just have tried and succeeded to use the built-in SD card on my Wemos LoLin32 Pro. It uses the sdcard.py script from the drivers/sdcard section and the following statements for mounting.

Code: Select all

import machine, sdcard, os
sd = sdcard.SDCard(machine.SPI(1, sck=machine.Pin(14), mosi=machine.Pin(15),
                   miso=machine.Pin(2)), machine.Pin(13))
os.mount(sd, "/sd")
For the new Lolin D32 pro, the Pins for the SPI interface have to be adapted into:

Code: Select all

import machine, sdcard, os
sd = sdcard.SDCard(machine.SPI(1, sck=machine.Pin(18), mosi=machine.Pin(23),
                   miso=machine.Pin(19)), machine.Pin(4))
os.mount(sd, "/sd")
You can also use the software SPI. In that case, the SPI device number is -1
Hi, Roberthh.
I did follow up your kind instruction but I'm not clear on last 3 response lines ? I'm using Wemos D32 Pro V2. I formatted my physical 8GB SD card by 4GB FAT only format only and wrote one simple text file to card by laptop to ensure that SD card is usual written before testing on MCU. Could you please guide more idea on below 3 lines error?

(2018, 12, 15, 15, 39, 13, 5, 349)
MicroPython v1.9.4-752-gd4d4bc582 on 2018-12-13; ESP32 module with ESP32
Type "help()" for more information.
>>>
paste mode; Ctrl-C to cancel, Ctrl-D to finish
=== import machine, sdcard, os
=== sd = sdcard.SDCard(machine.SPI(1, sck=machine.Pin(18), mosi=machine.Pin(23), miso=machine.Pin(19)), machine.Pin(4))
=== os.mount(sd, "/sd")
Traceback (most recent call last): #errror message line 1
File "<stdin>", line 3, in <module> #error message line 2
OSError: [Errno 19] ENODEV #error message line 3
>>>

User avatar
Roberthh
Posts: 1699
Joined: Sat May 09, 2015 4:13 pm
Location: Rhineland, Europe

Re: New Lolin D32 Pro with 4MB PSRAM

Post by Roberthh » Sat Dec 15, 2018 10:15 am

That's hard to tell. My experience is varying. With the ESP32 port, I have an 8 G Samsung card, which fails, and a 32 G Sandisk card, which works well, and so on. On a PyBoard, all card work well

wr300000
Posts: 22
Joined: Sun Jan 14, 2018 3:54 pm

Re: New Lolin D32 Pro with 4MB PSRAM

Post by wr300000 » Sat Dec 15, 2018 2:48 pm

Roberthh, you are right , problem was on SD card itself. My side, there are SanDisk and Apacer are working well. Thank you for your support again.

echoshack
Posts: 2
Joined: Mon Dec 31, 2018 6:30 am

Re: New Lolin D32 Pro with 4MB PSRAM

Post by echoshack » Mon Dec 31, 2018 6:45 am

[quote=Roberthh post_id=30171 time=1536994351 user_id=601]
That#s hard to tell without knowing the exact reason @mike teachman had. The obvious observation is, that in his set-up the timing of reset and GPIO0 do not match. GPIO0 low is too late with respect to the end of the reset pulse. But the reasons could be:

- GPIO0 is scanned too early (-> Lolin)
- the USB/UART bridge or the transistor circuit switche too slow (->Lolin)
- the controlling PC send the switch command too late (->PC)

Assuming that Wemos is testing their devices, I tend to the third explanation. But without testing it#s hard to tell.
[/quote]

I purchased 3 D32 Pro 2 of them firmware programmed ok and 3rd I had to toggle the reset button. The issue was the U4 Auto Flash chip pin 6 had a bad joint hold down with a pin and it worked. Luck had a solder iron very pointed bit and re-soldered. Fixed OK. Pin 6 looking at the top end of the TFT connector 6pin chip to right pin 6 is on left/top pin of 3 pins closest to Processor. I was able to put a test meter on pin and press reset as was not getting a change until re-soldered.

My 1st post on forum, think I have entered it correctly Tony VK3ZTR

Post Reply