new WiPy can't connect

Questions and discussion about The WiPy 1.0 board and CC3200 boards.
Target audience: Users with a WiPy 1.0 or CC3200 board.
Post Reply
Posts: 6
Joined: Sun Nov 11, 2018 8:11 pm

new WiPy can't connect

Post by johncblacker » Tue Jan 22, 2019 9:03 pm

I just received a new WiPy board, put power to it and I get a blue light flashing about every 4 seconds; however, I can't connect to the board with telnet, nor can I connect my tablet to it's AP - which is asking for a password and I've tried python, micropython and micropythoN to no avail. Telnet seems unable to connect either. Don't know what to do, other than buy the expansion board with the USB connector on it.
Anyone have any ideas? I saw somewhere about doing a "hard" reset, but couldn't find instructions on how to do so. I tried holding down the reset button while supplying power, but that didn't seem to help.
Thanks in advance.

Posts: 2
Joined: Wed Jan 23, 2019 3:20 am

Re: new WiPy can't connect

Post by washcycle » Wed Jan 23, 2019 3:22 am

Did you try a safe boot?

"In order to fix this you can safe boot your module. This will prevent and from being executed and will drop you straight into the interactive REPL. After reset, if P12 pin is held high (i.e. connect it to the 3V3 output pin), the heartbeat LED will begin flashing orange slowly. If after 3 seconds the pin is still held high, the LED will start blinking faster. In this mode the module will do the same as previously explained but it will also select the previous OTA image to boot if you have updated the module via the OTA update procedure (updates performed via the firmware update tool do not count). This is useful if you flashed a OTA update that breaks the device." ... eboot.html

User avatar
Posts: 2438
Joined: Sat May 09, 2015 4:13 pm
Location: Rhineland, Europe

Re: new WiPy can't connect

Post by Roberthh » Wed Jan 23, 2019 6:23 am

You are aksing at the worng forum. Go to and look into the documentation, e.g. ... elnet.html
The default password for the AP A sample script to connect in STA mode to your router is here:

Post Reply